Bricking it, in case I brick it….

Right, let’s start with a post I wrote a couple of nights ago….

Here’s something I never thought would be possible. A blog entry entirely typed on an Amiga. Well, sort of. As you know, I’m a massive fan of the humble Amiga. A love that has never died, despite Amiga being locked away in a cupboard for the past 20 years, and only seeing the light of day several years ago to stop the battery from leaking. It’s always been at the back of my mind that I should do something with it, and I’m so much more closer it’s untrue.

Now you notice above, that although I said that I typed this on an Amiga? Well, it’s a half-truth. I’m typing it on an emulator, but still, everything is there. This is genuine Amigta software, being saved onto a floppy disk (image), which, if this works, will be copied over to a network drive and uploaded to MV. If you’re reading this, I managed to do it. If not, then… erm. wasn’t this a waste of a Tuesday night?

So, anyway, I bet you’re wondering why the sudden interest in the Amiga again after all of these years? I’m sure I’ve mentioned along the years that one of my favourite games was “Arcade Pool” by Team 17. A cracking little top-down pool game, and definitely one of my most played games, especially seeing as it was one of the few games I actually bought from a shop.

Anyway, I was bored on Sunday afternoon. The “Snooker Shootout” had finished, and I fancied something to eat. I popped downstairs, and Daddykins happened to be watching a train video. The background music just happened to be that exact same music used in Arcade Pool! I always thought it was an original composition used especially for the game, but apparently not! It turns out the music used is the “Fig Leaf Rag” by Scott Joplin. Huh!

Well, all of those memories just came flooding back. I just had to play it again. Off I pop to download UAE, I dig out my A1200’s ROM dump which I created back in 1996, and also a disc image of Arcade pool, and I was in AGA enhanced, ball clacking heaven once again.

The fun didn’t stop there, however, as one thing I remembered, was that a while ago, I’d downloaded some disk images, from some old machines that, coincidentally, Team 17 had left over from their Worms development days. If I remember, I’ll insert a link here to where you can find them – there’s a whole video on YouTube. I was surprised to find that the one I tried (an image from an A1200’s hard drive) actually worked! It loaded up, booted, and I could use the machine just like it had been, when it was switched off for the last time some time in the 1990s. In fact, one of the pieces of software stated that it was something like 8,000 days over its 30 day trial period. Ooops.

I played with it for a bit, got bored, and seeing that it was only a copy of the image, I decided to just “wipe” it, and install Workbench 3.1 on it. Something I hadn’t done since I got my Amiga hard drive some time around 1994, early 1995.

You know, this has got me in one of those memory rabbit holes. It must have been after Christmas 1994, but can’t have been much after. Daddykins and I had been down to a shop in Leeds to get the drive. I’ve got conflicting memories of having my CB radio in the car with me, something I got for Xmas 1994, but I also remember getting this HDD for my birthday that year, which is before Xmas. It was also the first time I heard “Have You Ever Really Loved A Woman” by Bryan Adams. I remember it being months before I’d heard it again, and apparently it was on general release in April of 1995, so it must have been before then. Dunno. If only Google was tracking my every move back then. I might have still had a record of it!

Anyhoo, that was almost a post on its own. Back to my experimenting. It turns out that I couldn’t properly format this disk image. Amusingly, the disk image was damaged, so it wouldn’t format properly. It’s the first time I’ve had a physically damaged disk image that couldn’t be fixed by a format!

Yeeeeah, well it went on for a couple of more paragraphs without not really saying anything else, and I’m back typing this into lowly old WordPress. Such a come-down. I’m happy it worked though. There were a couple of keymap challenges on the way – despite installing the GB keymaps, it still gave me all of the settings for the US, and I had to change them manually. I forgot that was a thing. Also, the # key seems to have vanished. Anyway, onto the main part of the post…. the HARD DRIVE!

Yes, I mentioned that my Amiga’s been sat in a dusty cupboard for many years now. Tonight, I pulled it out of its cupboard, and ripped the plattery goodness from its deep underbelly.

There’s a date code of April 94 which would coincide with what I thought. The next step is wiring it up The drive is a Conner CFN250A, though I’m sure you can work that out from the pic above. Apparently it’s just IDE, so I’ve literally just ordered a cable set from Amazon. Could it be money down the kermit, or am I going to spend the weekend wallowing in so much nostalgia, the grey hairs in my beard will retract? You’ll have to wait and see…

Published by

MercuryVapour

I'm a man of few words. Any questions?

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.