My new toy

What’s got 2 legs, drinks crap beer and spends far too much in charity shops?

Well, I doubt I even need to answer that question, for you know that idiot is me. When it comes to charity shop shopping, I have two rules, never buy anything over a fiver, and never buy anything electrical.

So, on Thursday, I bought a £6 tape recorder.

This isn’t just any tape recorder, it’s a 4-channel tape recorder. Something I’ve never seen before, but apparently, they were once a thing. And this one is in really good condition

For some time, I’ve been after something that can play tapes. I’ve been after one to hook up to my computer, as I still have a load of tapes from my childhood to go through, and convert. I’m sure I was an absolute scream when I was 9, but it’s things like the old radio clips I want to convert. I do have a USB one, but the sound quality is dubious at best. I wanted something a but more… sturdy.

On Thursday, after knocking back a bag of chips for my dinner, I sauntered back to work. and decided to check out the Alice House charity shop. I was on the mooch for CDs, after only picking up a small amount on my travels. Before I even got to see the rotating plastic demons, something caught the very corner of my good eye. It looked like a tape recorder. And, clearly it was! I took it over to the little seating area they have, and by the time I’d sat down, a complete stranger said “You’ve got a bargain there!”. Upon closer examination, the sticker shows that it had only been PAT tested the day before, so yeah, it looks like I was indeed the first one to pick up the bargain!

Now, despite the obvious difference of having more knobs than a Taiwanese brothel, I didn’t quite know what I had hold of. Turns out it wasn’t just any old tape recorder. This beauty has the rare ability to record an all four tracks of a cassette tape. For the uninitiated, cassettes tapes have four tracks on them, but you only ever hear two of them at a time, the left and right channel. You turn the tape over, and you hear the other two left and right channels. This particular recorder uses all 4 tracks on the tape at once. Back in the day, it was a simple and relatively easy way to get a multi-track setup for home recording.

Last night, I plugged it in to make sure it all worked. And it did! One slight problem was that it was playing all 4 tracks at once, meaning at Side A was being played forwards, and Side B was being played backwards. 4 channels, y’see… there must be a way to have it just play stereo, but time was getting on, and I demoted it to the cupboard. I had a feeling it might have stayed there for a while.

I was speaking to a lad at work who knows more about this type of stuff than I do, he said just change the pan and tilt controls, and set channels 1 and 2 to L/R. This was too obvious to work

My interest in the device was rekindled. I’d planned in my head how I was going to announce my new bargain to the world. I hadn’t knocked up a Youtube video for a while. My camera battery was charged AND I knew where all the bits of my tripod were. This was all falling into a place.

I even got home and shot the beginning of the video. There was also a truly hilarious joke that I was going to include that saw me plug the power adaptor in, I’d then turn the light off, and then edit it so it looked like it tripped the lights, followed by a truncated “OHHH, FUUUU.”, and then immediately cut to the close-up shot of the tape recorder all set up and working, followed with “Only joking!”

This is where karma kicked me right in the balls. I’d got it set up, camera positioned, aaaand, the power supply for it went south. The power light was flickering, and the output lights were jumping around. I was not amused. Turns out the bit of cable that goes into the power supply is intermittent. Looks like someone’s picked up the (relatively heavy and brick-like – you can see it in the bottom left of that screenshot) power supply by the cable, and stretched it to near breaking point. Could this be the reason why it looked so good? Was the previous owners’ attempt to use it thwarted by a small piece of cable? I will never know,

One thing I do know is that it’s working again, after fashioning a makeshift splint from a bit of masking tape and some cable ties. I’ll farthom out a more glamorous s

I’ve yet to hook it up properly to my computer to have a proper play around with it, but I’m eager to see if it sounds as good as it looks…

Hard drive woes 2012, part 1…

Good lord, I bet you thought I’d fallen off the face of the earth. 2 months without an update. I’m afraid I’ve had another one of those “writers block” periods, where anything I write down blog-wise is just got enough to meet with my high standards of complete and utter tripe. Today, I shall strive to meet, nay even exceed my own lofty demands, as I begin to tell you, and explain in minute detail the problems I’ve currently been having when it comes to hard drives, or more exacter, my 2Tb LaCie Network Space 2 NAS drive.

To put it simply, a NAS drive is a network drive. A little box, whose sole purpose is to sit at one end of an ethernet connection, and serve me data.

“It’s easier than adding an internal drive to my computer”, I thought.

“It’ll be more convenient than leaving my computer on all the time”, I thought.

“It’ll be fun”, I thought.

To be fair, it was all of those three things, until Tuesday night. I’d been out to the Steak club. It’s not a club, but you can buy steaks for cheap. It was delicious. I returned home, and tried to access the drive through the network. Nothing. Not even the smallest hint of a sausage. Well, there was, because I could “ping” the drive on the network, but couldn’t access anything else. Not even the power button was responsive

“Joy”, I thought, as I ripped the power cable out of the back. It was then, when my nice little network drive, became nothing more than a solid, black brick. It would do one of two things, either start flashing red/blue after a few seconds, or slowly flash blue. I’ve left the drive in both of these modes for 24 hours, but still, nothing to report. Of course, just like any tech savvy idiot, I whinged on Twitter…

Bah. Looks like the NAS has given up the ghost. flashing red/blue light on Network Space 2 2Tb? Terminal?

Their reply was a little optimistic…

@mercuryvapour Hi, if its rhythmical red/blue/red/blue that means the automatic backup is in progress.

Yup, I checked the manual, and there it was, the flashing blue/red. I was almost excited, until I realised I’d left the drive in this state for 24 hours. I got back to them…

It is blue/red. Starts about 10 seconds after switch-on, been flashing like this for 24 hours, no other response from drive

I sat, and waited for what would hopefully be a nice, long list of steps I could get around this…

If the drive doesn’t work, you should get in contact with our support guys to investigate whats going on with it.

YE…. oh. You could almost hear my heart deflate, as I stared at the flashing box. It’s crypt of data, cuttently sealed, in a plastic shell, designed by Neil Poulton. the whole purpose of this blog entry is to see if anyone else has had the same problem, if they got around it, and if they avoided having to contact technical support…

THINGS I KNOW:-

If I need to crack it open, There’s just one drive in the box, so that should mean there’s no RAID shit to worry about. It’s either in ext3 or ext4 in XFS format (EDIT: SEE note below), which all versions of Linux should support. there are 10 partitions…

A couple of days before its death, I pulled the logfiles off it, though I doubt they’d give me any insight as to what’s wrong with it, they’ll at least give me some information on how the drive lived before it dies.

Line 57: May 26 23:24:29 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Disk 4 - /dev/sda - enabled]
	Line 60: May 26 23:24:29 NetworkSpace2 [DEBUG resource.set@460] Setting config value unicorn.storage.volume.root_device to [/dev/sda2]
	Line 65: May 26 23:24:30 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 1 - /dev/sda9 - enabled]
	Line 66: May 26 23:24:30 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 2 - /dev/sda8 - enabled]
	Line 67: May 26 23:24:30 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 3 - /dev/sda7 - enabled]
	Line 68: May 26 23:24:31 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 4 - /dev/sda6 - enabled]
	Line 69: May 26 23:24:31 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 5 - /dev/sda5 - enabled]
	Line 70: May 26 23:24:31 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 6 - /dev/sda4 - enabled]
	Line 71: May 26 23:24:31 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 7 - /dev/sda3 - enabled]
	Line 72: May 26 23:24:32 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 8 - /dev/sda2 - enabled]
	Line 74: May 26 23:24:32 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 9 - /dev/sda10 - enabled]
	Line 75: May 26 23:24:33 NetworkSpace2 [DEBUG resource.handle_event@262] Updating [Volume 10 - /dev/sda1 - enabled]

I feel I’m going to have fun and games with this…

EDIT: The fun and games, of which there were none of, are described in the post following this one. I’m not up on my Linux filesystems, so I’m not sure if there’s a big difference between what I originally said (ext2/3) or XFS. It may be possible to read XFS partitions in Windows, but it’s probably easier, quicker and less time consuming to download a live Linux CD and go nuts with it from there.

Goodbye my trusty friend…

Oh, I can’t believe this has just happened. In fact, I have a little lump in my throat as I type this, but I have broken my trusty little Acer camera, which has been the stalwart of my photography since winter 2006. Over those 4 years, it’s not been far from my pocket, capturing the entirety of my trips to Edinburgh, Paris and Berlin over those past 4 years, along with many thousands of other images which have resided mainly on my flickr account since then.It’s even seen uses in situations where my main camera is a bit too bulky to carry around

Unfortunately, as quickly as it came into my life, and filled it full of wonderment, it exited, and has already left a gaping hole. I was taking some random photos earlier, mainly of a delicious curry I’d made, complete with incredibly undercooked chillies, when the batteries ran out. “Gah”, I thought as the lens retracted, and the power went off.

I slapped it in my trouser pocket, and proceeded to take the charger upstairs with me. As I bent over, to plug it in, I heard a shuddering crack. Knowing that there was only one thing my pocket, except for my keys, I knew something had gone horribly, horribly wrong.

And, indeed it had. My faithful little Acer, had, for some reason, switched itself back on and the lens had fully extended while in my pocket. I’d say that I’d accidentally switched it on with my massive penis, but these jeans are quite thick and the “on” button is quite small, meaning that any accidental button pushing with my enormous phallus is highly unlikely.

I removed it from my pocket to find the lens jammed in partially, After switching it off and back on, the lens motor sounded particularly unhealthy, and the lens got stuck halfway. I was presented with a “lens error”, and the camera switched itself off.

I’ve enjoyed using it, and have put it through probably more than it was designed for. The case is scratched to hell and back. The lens cover itself would occasionally get stuck when opening, The screen’s cracked, and there’s dirt on the sensor, as shown here…

The dirt is that little dark patch on the left, in case you didn’t know, or are thick. As can be seen in that photo, however, is that even after that amount of time, it still takes a good picture.

The batteries are on charge, so hopefully after a small amount of charge, it’ll be good to go again. It’ll be a sad day when it finally enters that little bit of drawer space in the sky.

I bet you thought I’d got lost…

You know, it’s always the same, I have a big long spell of blogging, and then I don’t do anything for two weeks. Oops. This wasn’t intended, but it seems I did the same last year, after the dizzying heights of the Berlin trip. Oh well.

Even for a British summer, the weather has been truly appaling. There hasn’t a day gone by where it’s not absolutely hoyed down at some point, or been so dull that it’s not even worth sticking your foot out of the door, never mind going around and doing stuff. Ever since I’ve came back from Paris, I have had absolutely nothing to look forward to… I tried to change this by arranging a trip to Countdown for me and Chris, but seeing as he has no holidays left, this has fallen through, leaving me once again, staring to the inky void, where the only light at the end of the tunnel is the reflection from the bottom of a beer glass. Even worse, is that it would have been my last chance to see it under its current guise.

On a lighter, and much happier note, Wayne has finally got back in touch after 18 months of being silent!! Unfortunately, he missed all of the email I’d sent to him in this time, thanks to NTL/Virgin’s policy of only keeping email on their servers for 90 days, but at least he’s still alive! Coatesy, however, is still radio-silent, and it’s looking less likely that he’ll ever get back in touch.

Christ, this is an amusing entry isn’t it? Laugh-a-bloody-minute.

To make things worse, morale at Employment Palace has hit an all time low. Once again, I can’t go into details, mainly because I’ll end up putting my fist through the monitor. This has depressed me more than anything, I think.

On another note, I’m an organ donor. Or rather, I’ve been for months, but I never bothered mentioning it before. I’m only metioning it now, because I’ve just found an old registration form I meant to send off, but never did. On the back of it, it states “Discuss your wishes with those closest to you, so they know your wishes should the time ever come… I’m sorry, I know whatthey mean, but surely that’s the worst way of putting it, ever? What do they mean by “should”? Do they suddently think I’m immortal, or something?

Ahem. On the subject of death, another reason I’ve not been updating much is the “dying” of Beastbits, my main machine… You may remember a few months ago, the 250Gb drive I had, started clicking, going all weird and just not working in general? Well, I replaced it with a 500Gb drive. And that’s on the way out too. It began with The Click of Death.

Eventually, strange things started happening The drive would disappear from Windows completely, and today, during the reboot, in the BIOS detection it wouldn’t reappear. Nasty. I decided the drive was duff. My curiousity got the better of me, and after a physical power-off, it reappeared.

Now, something was up, and I decided to back everything up to an external HDD. During ther copying process, it halted with a CRC error. Not good. Files were on the bad sectors! Oooooo!

I happened to note the name mentally of the corrupt file. Thankfully, it was just an outdated SQL dump I’ve done from my website, and wasn’t of much use anyway. The rest of the backup passed without a hitch. Everything else copied. For a bit of mirth, I decided to copy the original file I’d had a problem with. It copied first time. To me, this began to sound like something more “logical” than physical.

Soooo, I powered up “Darik’s Boot And Nuke”. I had used this in the past to “fix” the bad sectors on the earlier faulty drive I mentioned. Anyway. I started it on this drive, and it failed. It quit with an error saying that the drive may have bad sectors. Duh.

Fair enough, this wasn’t playing ball, so I grabbed the diagnostic software from the Samsung website. I wasn’t expecting miracles. Still, I ran it, and there they were, the bad sectors…

Goosed.

Fair enough, at least they were official.

I wasted at least 3 hours of my finite time on this planet allowing the disk check to finish. It prompted me to perform a disk erase. Meh. All backed up. It can’t do any harm. After all, these sectors were goosed, so another few hours later, the entire hard drive was erased, and I ran another diagnostic check Now, thanks to that photo, I had the exact location the bad blocks. Imagine my surprise as it skipped over them without a single bit of hesitation.

OK, so unbelievably, the drive was back to its normal self. All of this took place on Monday night, so I formatted the drive while I was at work on Tuesday. I returned home, and copied all of the stuff from the external backup drive onto it. And, tonight (Friday), it has gone back to the original problem of the click of death. Joy!

In a thread on Glens’ forum, I mentioned my problems, and although Crag has a very valid point, it’s still a 100% failure rate. And, I can’t even send it back either, because the only way it will detect bad sectors is obviously after the disk has been in use for a few days after an erase, which means there has to be data on it. And, seeing as I know the sort of ahem… “data” I keep on it, I’d rather not let it out of my sight!